.:: Puntotic ::.

jueves, 30 de abril de 2009

Android y su compatibilidad

Android 1.5, como todo software Open Source, no tiene la obligación de mantener la compatibilidad con versiones anteriores.

Ahora bien, esto supone un gran problema para fabricantes y desarrolladores, ya que la actual versión del sistema operativo no funcionaría correctamente en algunos de los dispositivos ya disponibles en el mercado.

En contraposición, están los desarrolladores, en el blog oficial se propone si se necesita correr la aplicación en versiones anteriores para las cuales intenta salvar ofreciendo parches.

Un sistema emergente como es el de la venta de aplicaciones el cual promete grandes beneficios en los próximos años ¿Puede permitirse esto?, ¿es rentable para un programador desarrollar una aplicación y tener que testarla sobre distitas versiones del framework?, la respuesta cuanto menos causa una terrible sensación de duda a la hora de ponerse manos a la obra.

Pongo un ejemplo: Si desarrollo una aplicación para Android que utilice reconocimiento de voz y el bluetooth estéreo, o simplemente la auto corrección de texto tendré que parchear mi aplicación para que sea posible correrla en versiones anteriores.

Y todavía hay que estar tranquilos, ya que es su primera versión, veremos a ver cuando pasen algunas más de ellas.

Etiquetas:

0 comentarios:

Publicar un comentario

Suscribirse a Enviar comentarios [Atom]



Enlaces a esta entrada:

Crear un enlace

<< Página principal